My Rinkel on web is inaccessible

Incident Report for Rinkel Service Status

Resolved

This incident has been resolved.
Posted Nov 27, 2025 - 07:49 CET

Investigating

The My Rinkel web environment is currently inaccessible. We're investigating the issue.
Posted Nov 27, 2025 - 07:45 CET
This incident affected: My Rinkel (Web).