Degraded voice quality to and from KPN network

Incident Report for Rinkel Service Status

Resolved

This incident has been resolved.
Posted Mar 22, 2025 - 15:42 CET

Investigating

Currently, some calls are experiencing sound quality issues due to a disruption at network provider KPN. We are in close contact with KPN and are closely monitoring the situation.
Posted Mar 21, 2025 - 09:30 CET
This incident affected: Inbound calls.