If you previously saw an "account blocked" error on your desk phone, this has been fixed. We'll continue to investigate the disruption.
Posted Aug 25, 2026 - 09:50 CEST
Investigating
Due to a disruption, desk phones may not connect, or may show an "account blocked" error. This isn't a problem with your account, we're investigating and will update this page as soon as we know more.
Posted Aug 25, 2026 - 09:37 CEST
This incident affected: Outbound calls and Inbound calls.