Incident Resolved. Our website and customer portal are now fully operational. Thank you for your patience!
Posted Jul 30, 2025 - 15:06 CEST
Monitoring
A fix has been implemented and we are monitoring the results. Website and customer portal should be reachable again.
Posted Jul 30, 2025 - 14:52 CEST
Identified
We are currently investigating an issue that is affecting access to our website and customer portal. Our team is working to identify and resolve the problem as quickly as possible.
Please note that voice services are fully operational and remain unaffected.